Overview
If SVG support is not configured, TeleScope won't generate image thumbnails or previews for SVG files when uploaded. This can be a problem when locating the right assets while searching if the preview thumbnails are missing.
Solution
<supportagent>
Pre-requisites
TeleScope Customer Environment Details - You should perform the below steps in the App instance.
</supportagent>
Diagnosis
<supportagent>
Agents should ask for a few asset IDs and check on the customer installation and confirm that previews weren't generated.
</supportagent>
When SVG support is not enabled, no SVG file should have previews, and all SVG uploads should be without a preview thumbnail. You should test with a few different SVG files since a few SVG files may fail on preview generation even if SVG support is enabled.
Steps To Fix
TeleScope's support for SVG isn't officially documented but it does generate previews for it through the ImageMagick I-Piece. Since this is not part of the official implementation, preview generation may fail for a few files intermittently.
OnDemand customers should raise a support ticket to have this configured for their installation, whereas On-premise customers can follow the steps listed below.
You can enable preview generation for SVG files through ImageMagick with the following steps:
- Add
svg
tosupported_keys
in com.northplains.ipiece.imagemagick.xml in (C:\Telescope\IPieces\config) for allconnection_name
keys. - Remove
svg
fromsupported_keys
in com.northplains.ipiece.vizview.xml in (C:\Telescope\IPieces\config) for allconnection_name
keys. - Restart Graphics Broker.
- Select Assets > File > Check Files to re-generate the previews.
Testing
Once the above steps are performed, you should be able to see thumbnails for a majority of the uploaded SVG assets.
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