Overview
After logging in through SSO, users might not be able to access specific websites and will see the “You are not authorized to view this page" error message instead of the website content.
Usually, this error message is tied to a "401 Unauthorized" error given by the SSO endpoint which is caused by incorrect authentication credentials.
Solution
Diagnosis
This can be confirmed by opening the Telescope Application logs and looking for a 401 error message.
[ERROR} - SingleSignOnLogin.defaultAction() - The server sent HTTP status code 401: Unauthorized
SSO is not part of the default configuration of TeleScope and not all customers have it, so you should also confirm that the TeleScope installation uses SSO by checking for the SingleSignOnGlobal.plist file at \TeleScope\Applications\tsweb.woa\Contents\Resources
.
Steps To Fix
- Open the file SingleSignOnGlobal.plist file under
...tsweb.woa\Contents\Resources
- Search for an entry in this format:
BASIC_AUTHENTICATION = {
BASIC_AUTH_URL="";
BASIC_AUTH_USER="";
BASIC_AUTH_PASSWORD="";
}; - Ensure that the information in each field is correct and update as necessary.
- Save the changes.
Testing
Users with SSO logins should be able to see the websites as expected.
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